How to solve following error npm WARN deprecated [email protected] ?

C:\Users\xxx>npm install -g ionic
npm WARN deprecated [email protected]: Please note that v5.0.1+ of superagent rem
oves User-Agent header by default, therefore you may need to add it yourself (e.
g. GitHub blocks requests without a User-Agent header). This notice will go awa
y with v5.0.2+ once it is released.

C:\Users\xxx\AppData\Roaming\npm\ionic -> C:\Users\avadhut\AppData\Roaming\n
pm\node_modules\ionic\bin\ionic
npm WARN [email protected] requires a peer of [email protected]^4.0.1 but none is installed. Yo
u must install peer dependencies yourself.
npm WARN [email protected] requires a peer of [email protected]^5.0.2 but none is installed
. You must install peer dependencies yourself.

My Machine configuration

node –version
v13.3.0
npm –version
6.13.1